Service has been fully restored. We are monitoring performance to ensure ongoing stability.
Thank you for your patience and understanding while we resolved this issue.
Posted Sep 16, 2026 - 13:26 UTC
Monitoring
A fix has been implemented by our third-party provider, and services are beginning to normalize.
We are closely monitoring system performance and will provide a final update once full recovery is confirmed.
Thank you for your patience.
Posted Sep 16, 2026 - 12:44 UTC
Investigating
We are currently experiencing delays in processing customer support tickets due to a third-party service disruption.
Our team is actively monitoring the issue with the vendor to restore full functionality as quickly as possible. We apologize for the inconvenience and will share updates here as they become available.
Posted Sep 16, 2026 - 09:29 UTC
This incident affected: Support Channels (Email Support, Phone Support, Web Form Support, Chat Support).