DMH - Email Delivery Failure

Incident Report for Veritone

Resolved

The email delivery issues have been resolved. We appreciate your patience throughout this process.
Posted Apr 23, 2026 - 01:49 UTC

Identified

The issue has been identified, and the team is currently working on a fix.
Posted Apr 22, 2026 - 18:29 UTC

Investigating

We are currently investigating the issue.
Posted Apr 22, 2026 - 17:10 UTC
This incident affected: DMH Services (Email Service).